ECU Tuning (& Diagnose) mit TuneECU / GuzziDiag / IAWDiag

  • Die Guzzifahrer aus dem Guzzisti - Forum (unter Guzzisti auch das rote Forum genannt) haben beim jährlichen Forumstreffen schon mal jemanden mit Erfahrung und GuzziDiag da. Da lässt sich dann wohl der Eine oder Andere die Abstimmung optimieren. Ist also wie Kai schon schrieb, in anderen Foren machen einige sowas.
    Ich hab auch keine Bedenken, das Mapping im Rahmen der Möglichkeiten zur Optimierung der Laufverhaltens und Kompensation der Serienstreuung zu modifizieren. Das dürfte den legalen Rahmen nicht verlassen. Es darf halt das Abgasverhalten nicht verschlechtern. Systeme, die da den Sensoren was vorgaukeln, um mehr Leistung zu erzeugen sind da dann eine andere Hausnummer...
    Aber haben wir das nicht schon früher bei den Vergasermotoren gemacht? Das war auch schon nicht legal...

    Hätte Gott gewollt, dass Moppeds sauber sind, wär' Spüli im Regen...

    Fahren statt putzen...

    Einmal editiert, zuletzt von miele ()

  • Moin,


    Ich finde das super, das du dich da rantraust ... garantie mal beiseite gelassen ... kann das wirklich was bringen ... und was motorschäden angeht... wir sind hier nicht bei apple oder google ... es wird niemand gezwungen sich ein custommapping aufzuspielen! Lasst die leute doch mal was tun ... wenn ich mir überlege was knubbler mit seiner sv macht ... da ist das hier alles ... minimalinvasiv.

  • Update 06.04.19:
    Ich hab Heute versucht die aktuellere Map auf meine ECU zu schreiben und es ist natürlich fehlgeschlagen :thumbdown:


    Soweit ich beurteilen kann, habe ich keine Fehler gemacht und alles wie vorgesehen durchgeführt (Sicherungen Licht gezogen, Batteriespannung über 12,5V gehalten, Map aus dem Internet auf Übertragungsfehler geprüft, usw.). Das Schreiben der neueren Map ging auch scheinbar reibungslos bis auf 100%, aber dann hat Murphy zugeschlagen und die Android Software meldete "Download fehlgeschlagen" und jetzt kann ich mich weder mit Android TuneECU noch Windows GuzziDiag/IAWDiag zur ECU verbinden (siehe Bilder), die ECU hängt entweder im Datenübertragungsmodus oder ist komplett tot. Motorrad ist jetzt jedenfalls erstmal stillgelegt, da geht nichts mehr.


    Bitte melden Sie sich an, um dieses Bild zu sehen.Bitte melden Sie sich an, um dieses Bild zu sehen.Bitte melden Sie sich an, um dieses Bild zu sehen.Bitte melden Sie sich an, um dieses Bild zu sehen.


    Ich hab dem Entwickler von TuneECU eine Mail mit Informationen zu dem Vorgang geschickt, mal gucken was der zurück schreibt. Ansonsten werde ich die Maschine dann wohl zum Händler schleppen und schauen, ob die noch was retten können. Das Fazit bisher ist erstmal ECU tot und dementsprechend teures Lehrgeld. Gebraucht gibt es ECUs zum Glück recht günstig in der Bucht, aber abwarten was der Händler sagt.


    Bitte melden Sie sich an, um dieses Bild zu sehen.
    Edit: Der Entwickler von TuneECU hat mir schon geantwortet :heil und hilft bei der Problem- suche/behebung, ich werde berichten :dup .
    Edit: Letzten Satz hinzugefügt
    Edit: Kontakt mit Entwickler

    3 Mal editiert, zuletzt von Sheepy ()

  • Update 2:
    Problem gefunden & behoben! :bier
    Ich habe entweder ein defektes Smartphone oder einen Kabelbruch im Lenkkopfbereich, deswegen hat das Map aufspielen nicht funktioniert. Tablet statt Smartphone, Lenker nach rechts eingeschlagen und zack - Map upload funktioniert in ~15 Minuten ohne Probleme, Gasgriffsensor neu angelernt, Motor läuft :dance


    Morgen werde ich erstmal mit meinem geeichtem Popometer die Unterschiede zwischen steinalt-Map und der 0134A0 Map ausprobieren, danach mal schauen ob ich noch mehr mache als nur das Update - für Heute war das genug emotionale Achterbahnfahrt :]

  • Servus Stefan



    Ich habe mir auch eine App für meine XR zum auslesen und schreiben für diverse Updates geholt und
    konnte dadurch einen teueren Werkstattbesuch ersparen. :]


    Die Geschichte dazu!


    Man sollte halt vorher die Betriebsanleitung lesen bevor man Hand anlegt. :peinlich
    Bei meiner XR löscht sich der Speicher für Kundendienste und das Datum nach 10 Minuten ohne Batterie.
    Da ich diverse Anbauten gemacht habe und dabei die Batterie für ein paar Stunden abgeklemmt war,
    war natürlich alles auf die Geburtsstunde zurück gesetzt. :wand
    Damit man dies wieder einstellen kann braucht man entweder eine Werlstatt oder diese App.
    Dort kann ich alle Fehlercode auslesen, zurücksetzen und diverse Sachen neu anlernen nach Einbau uvm.
    Jedoch würde ich mir nie zu trauen in der ECU was zu verändern dazu fehlt mir ehrlich das Wissen. :]
    Bei den heutigen Hochleistungsmotoren sollte man wissen was man tut.


    Nun aber zu nächsten


    Ich habe entweder ein defektes Smartphone oder einen Kabelbruch im Lenkkopfbereich,


    Hattest Du wegen Deiner Vermutung schon vorher Probleme :denk


    Fehlercodes im Display oder Motor der nicht ansprang.


    Wundert mich das mit dem Lenker plötzlich das funzt oder denkst Du das dies Zufall war :denk
    Erinnert mich gerade an meine Shiver ... dort war ein Steckerpin aus den Stecker gerutscht
    da dieser nicht richtig verbaut wurde und je nach Lenkeinschlag wurde der Schlüssel nicht erkannt. ;)



    Gruß


    Manni :wink

  • Na der Kommentar zur Capo macht mich natürlich neugierig. Ich möchte Deinen Threat nicht kapern, jedoch die Frage stellen ob einer der Capofahrer mir per PN den Kontakt herstellen kann? Danke.
    Was jetzt wieder hierher gehört, kann man mit dem Teil nur tunen oder auch zum Beispiel eine Level niedriger die „Serviceanzeige“ zurücksetzen?

    Gruß
    Dinoz

    Rettet Euch vorm schwarzen Karl!:jester

    Sammelt fleißig grüne Smileys innerorts!

    Einmal editiert, zuletzt von Dinoz ()

  • Kurvensau:

    Zitat

    Hattest Du wegen Deiner Vermutung schon vorher Probleme

    Kann sein. Ich hatte schlechten Leerlauf bei Kaltstart (musste die Drehzahl manuell hoch halten damit der Motor nicht abstirbt), das kann / sollte aber an der defekten Lambdasondenheizung liegen - die Sonde gibt solang sie kalt ist falsche Werte an die ECU weiter und damit ist der Motorlauf eher unschön. Bei warmen Motor (& damit warmer Sonde) trat das Problem aber nicht auf, sollte also nix damit zu tun haben. Fehlercode hatte ich nur den für die Sondenheizung, sonst alles i.O.

    Zitat

    Wundert mich das mit dem Lenker plötzlich das funzt oder denkst Du das dies Zufall war

    Das hat mich auch gewundert, aber der Entwickler von TuneECU war sich selbst bei Ferndiagnose sicher, dass es ein Kontaktproblem sein muss. Ob das jetzt an der ausgenudelten USB-Buchse am Smartphone, einem teilkorridiertem Datenkabel am Motorrad oder gar anfänglichem Kabelbruch am Lenkkopf lag - keine Ahnung. Mein Workaround heute war einfach - wenn sich TuneECU in 2-3 Sekunden mit der ECU verbinden kann, ist die Leitung ok. Dauert es länger, stimmt was nicht. Also alle Kabel nochmal fester zusammengedrückt und schon verbindet es sich in Sekunden und ich konnte die Maps innerhalb von 5-6 Minuten lesen/schreiben. Vorher mit Kontaktproblem dauerte das Lesen 30 Minuten und Schreiben 20 Minuten - was laut Entwickler viel zu lange ist.


    EDIT
    Dinoz: Serviceanzeige zurücksetzen geht glaube ich über das Dashboard bzw. den Zweitschlüssel. TuneECU kann vieles, inkl. Fehlerspeicher löschen, Drosselklappen & Gasgriff anlernen, verschiedene Dashboard-tests uvm. .. ob Serviceanzeige rücksetzen dazu gehört weiß ich nicht, kann man nur bei Verbindung mit ECU einsehen in der App.

  • Update 07.04.19:
    Heute war es so weit, ich hab den ganzen Tag Maps bearbeitet, geschrieben und ein halbes duzend Testfahrten gemacht, hier mal die ersten Erkenntnisse (die Testfahrten waren immer gleich, ca. 20km Hausstrecke in der Nähe):


    Update von Map 013299 auf 0134A0 (nur Zündzeitpunkt im Bereich 0-18% Gas & 2500-3000 U/min geändert):
    - Die neuere Map fährt sich in dem Bereich etwas sanfter, Motor scheint weniger Tendenz zum "Verschlucken" zu haben, Unterschied ist aber gering.


    Einspritzung: um 3% über die ganze Map erhöht (Motor fetter gestellt):
    - Erzeugt einen spürbaren aber geringen Unterschied. Untenrum (Teillast bei 2-4k U/min) gefühlt weniger Leistung, aber auch sanftere Lastwechsel. Obenrum (Teillast ab ca. 50% Gas und Drehzahl bis hin zu Vollgas) definitiv mehr Dampf im Kessel, nicht viel (vielleicht 2-3 Nm), aber durchaus spürbar. Subjektiv waren Motor und Kat weniger heiß.
    - Vorerst vermute ich, dass meine Annahme mit dem leicht magerem Motorlauf (zumindest bei WOT, wide open trottle, also Vollgas) korrekt war und ich mit den 3% obenrum zwar eine Verbesserung erreicht habe, aber natürlich bei weitem noch keinen optimalen Wert - Prüfstand oder wenigstens AFR / Breitbandlambda Werte braucht es hier schon um in allen Drehzahlen optimale Werte zu erreichen. Untenrum waren 3% eher eine Verschlechterung, da ist die Serienmap wohl noch korrekt(er).


    Leerlaufdrehzahl: bei 10°C auf 1700 U/min und bei 20°C auf 1600 U/min erhöht (Serie 1500 U/min):
    - Scheint zu funktionieren, ist aber nur eine vorläufige Notlösung bis ich die Lambdasonde ersetzt habe, um die Probleme mit schlechtem Leerlauf los zu werden.


    Gasmapping T: Totzone bei 2-6% Gas entfernt, Übergang von 80% auf 100% Gas weicher gemacht:
    - So ist die T-Map für mich nutzbar, ohne diesen einprogrammierten Leerweg am Gasgriff fährt sich das viel besser als Serie. Es war bei den Testfahrten nicht ganz so ruckfrei wie Serie, aber das kann ich noch "glatter" programmieren und hat vielleicht auch was mit Umgewöhnung zu tun -> mehr Tests notwendig.


    Gasmapping S: Totzone bei 90-100% Gas entfernt, Übergang von 0-5 % weicher gestellt:
    - Kein wirklicher Unterschied spürbar, Veränderung wohl zu gering. Gasgriff im Bereich >90% aber <100% hat man halt auch selten, die Totzone da oben kann durchaus bleiben. Wirklich weicher wurde der Übergang von 0-5% nicht -> mehr Tests notwendig oder einfach original lassen.


    Gasmapping R: Auf "Renn" Modus geändert, quasi wie S-Map:
    - Geht nicht, Aprilia hat irgendwo feste Limits einprogrammiert - mehr als ~50% Drosselklappe führt direkt zu Motor-Notlauf, da greift eine Drehmomentbegrenzung (die ich aktuell nicht sehen / ändern kann) und schaltet den Gashahn ab =) .


    Das Fazit ist: Ja, man kann was verbessern - bzw. muss man das mit Sportauspuff, Sportluftfilter & veränderter Ansaugung sogar - mit einer ordentlichen Optimierung kann das dann auch richtig Spaß bringen. Ich rüste meine Ansaugung aber erstmal wieder richtung Serie zurück und lasse die Einspritzung / Zündung Serie - bis ich auf einen Prüfstand komme und ordentlich abstimmen (lassen) kann. :dup

  • Danke, dann schaue ich mal. Nein bei der Capo kann man das nicht mehr so zurücksetzen wie bei der Shiver oder Dorso.

    Gruß
    Dinoz

    Rettet Euch vorm schwarzen Karl!:jester

    Sammelt fleißig grüne Smileys innerorts!

  • Sheepy
    Dein Engagement finde ich super und hoffe, dass es für Dich die Beste Lösung ist.


    Ich möchte aber auf ein anderes Gerät hinweisen, dass ich für wesentlich besser halte und auch in den nächsten Monaten verbauen werde.
    Es wird die serienmäßige Lambdasonde benutzt, die dem RapidBike die Daten liefert. Es wird in Echtzeit das Gemisch aufbereit ohne lästige Einstellung auf dem Prüfstand!
    Geliefert wird sie mit einem "Basiswissen" und lernt selbstständig dazu.


    https://rapidbike-bdp.de/


    Riesiger Vorteil ist, dass auch beim mechanischen Verschleiß im Laufe der Jahre die Einspritzung sich dynamisch anpasst. Es ist kein Mapping das zum Zeitpunkt x auf dem Prüfstand eingestellt wird.


    Kannst Dich gerne belesen, bei Bernd Dewald informieren oder vieles in anderen Foren lesen.

    Das perfekte Symbol unsere Zeit ist der Laubbläser:
    Er verlagert ein Problem von einem Ort zum Anderen, ohne es zu lösen und
    benötigt dafür wertvolle Energie und macht dabei eine Menge Lärm!


    Zwei Arme, zwei Beine und zwei Zylinder!
    :jester

  • F.Y.I.
    der Rapid Bike Evo ist nicht mit der Lamdasonde der 750‘er Shiver oder Dorsoduro kompatibel.
    Da passt nur der einfache Easy... der nutzt keine Sonde ...der fettet nur an und hat nur ein starres Kennfeld.
    Kannste vergessen... Quelle Micron Systems und UG-Raceingparts.

    ...und Moin...
    Kai der Ammerländer

    sorry ich bin offline... :ditsch

    so lange noch ,bis es zum 12ten Mal röhrt :bier


    WARNUNG: Beiträge dieses Benutzers können Spuren von Ironie, Sarkasmus, Uran, purer Boshaftigkeit, Fachwissen und Erdnüssen enthalten ... :aetsch

  • Hmm, für die DD 750 gibt's den EVO. Kann mir nicht vorstellen, dass es bei der Shiver dann nicht klappt.


    https://bdperformance-shop.de/…duro-750-09-16::2131.html


    Ich glaube der Easy nutzt auch die Lambdasonde, aber nur im Teillastbereich. Hilft also kaum, wenn es so sein sollte.


    Gesendet von meinem SM-G920F mit Tapatalk

    Das perfekte Symbol unsere Zeit ist der Laubbläser:
    Er verlagert ein Problem von einem Ort zum Anderen, ohne es zu lösen und
    benötigt dafür wertvolle Energie und macht dabei eine Menge Lärm!


    Zwei Arme, zwei Beine und zwei Zylinder!
    :jester

    2 Mal editiert, zuletzt von Köcky ()

  • Wie gesagt, hatten mir zwei Firmen bestätigt, dass der Evo nicht für die 750er wegen der merkwürdigen Arbeitsweise der originalen Lamdasonde funktioniert. Man könnte aber eine weitere Sonde mit einem Einschweißgewinde im Abgasweg einbringen....
    Empfohlen wurde aber von Micron System eine Abstimmung auf dem Dynojet Prüfstand für 450€, oder der Easy von UG-RP...

    ...und Moin...
    Kai der Ammerländer

    sorry ich bin offline... :ditsch

    so lange noch ,bis es zum 12ten Mal röhrt :bier


    WARNUNG: Beiträge dieses Benutzers können Spuren von Ironie, Sarkasmus, Uran, purer Boshaftigkeit, Fachwissen und Erdnüssen enthalten ... :aetsch

  • Ich habe gesehen, dass die alte Map der Shiver andere Zündzeitpunkte hat, um 3.000 Undrehungen bei wenig Gas wurde vorher auch vor OT gezündet und jetzt nach OT. Genau da blubbert/schießt die Maschine auch.


    Ich kenne nur das neue Mapping und deswegen jetzt zu meiner Frage: Blubbert die Maschine mit dem alten Mapping auch ähnlich? Bin am Überlegen das mit Tune ECU zu ändern.


    BTW:

    Eine elektronisch gedrosselte Shiver zu entdrosseln funktioniert mit Tune ECU, der downloadbaren Map und den Lonelec Kabeln wunderbar.

  • Sheepy Vielen Dank für deine Beiträge! :bier
    Ich habe es mal verfolgt seit letzem Jahr, und das hört sich doch wunderbar an :dance
    Da hat einer Spaß am Tüfteln und optimieren gefunden;o) Ich habe meiner Diva ja nen Quickshifter, Sc-Projekt anlage und Luftfilter gegönnt. Das ist Fahrdynamisch und Soundtechnisch schon eine Welt, alleine das die Originale Suppenschüssel (ESD) sage und schreibe 11KG wiegt:bump. Jetzt fehlt nur noch ein Map mit etwas mehr Bums, bzw etwas gleichmäsigeren Drehmomentkurve finde ich. Ich bin sehr gespannt was du da noch hinzauberst;o):jop

  • Ich kenne nur das neue Mapping und deswegen jetzt zu meiner Frage: Blubbert die Maschine mit dem alten Mapping auch ähnlich? Bin am Überlegen das mit Tune ECU zu ändern.

    Ja, das ist mit dem alten Mapping ohne den späten Zündzeitpunkt auch so, da hat sich durch das Update (subjektiv) nichts verändert. In welche Richtung (mehr/weniger) willst Du mit dem Blubbern?

    Jetzt fehlt nur noch ein Map mit etwas mehr Bums, bzw etwas gleichmäsigeren Drehmomentkurve finde ich. Ich bin sehr gespannt was du da noch hinzauberst;o):jop

    Drehmoment gleichmäßiger wird schwierig, das ist doch Original schon extrem linear - es sei denn Du meinst das Gasmapping, das ist leicht & schnell linearer geschrieben. Im Moment passiert nix, weil Wartungsstau und Geldmangel - ich denke frühstens Anfang Winter werde ich auf einen Prüfstand kommen und weiter berichten können.:wink

  • Drehmoment gleichmäßiger wird schwierig, das ist doch Original schon extrem linear - es sei denn Du meinst das Gasmapping, das ist leicht & schnell linearer geschrieben.

    Ich Denke, das dass dann der Springende Punkt ist. Weil Ansprechverhalten ist ja Top, aber sehr ruppig. Wenn ich das Verhalten aber abändern würde richtung Touring, dann würde ich mich selbst nochmal drosseln, da 48ps mit Gasanschlag... :wand:bump:ddown

  • Hallo!


    Ich war leider aus Zeitgründen länger nicht mehr im Forum unterwegs.

    Aber Schön das jemand das Thema aufgreift und das es inzwischen Tools gibt um das Kostengünstig im Hobby Bereich zu ermöglichen.


    Ich habe letzten Sommer auch mit dem Thema angefangen, aber nichts dazu geschrieben etc.

    Es gibt diverse OBD Tools/Software die schon etliche Jahre mit unseren Mopeds umgehen können.

    Ich habe mir dazu ein Kess V2 OBD flash tool incl. passender Software ausgeliehen.

    Die Maps wurden mit der mapping Software Winols angepasst.

    Außerdem habe ich ein Prüfstand optimiertes file von einem Tuner gekauft um einen Vergleich zu haben.

    Ich habe aktuell das optimierte file drauf und bin noch nicht dazu gekommen in die anderen Maps zu schauen und zu testen.

    Mometan bleibt wegen Nachwuchs und Arbeit leider nur wenig Zeit für anderes übrig.


    Ich werde mal die files von TuneECU und Kess vergleichen ob die kompatibel bzw. verschlüsselt sind.

    Wenn es mit TuneECU kompatibel ist werde ich mein gekauftes file gern via PM zur Verfügung stellen.

    Gruß

    Michael


    Due cilindri e basta! :bier

  • Das hört sich doch gut an ;)
    Hast du denn mal nen Unterschied rausfahren können zwischen Original und dem Getunten Map?:heil

  • Ich hatte leider keinen direkten vorher/nachher Vergleich.

    5-7 PS und 3-5 NM netto ohne Marketing versprechen sind jetzt auch nicht die Welt die man bei gleicher Fahrweise sofort spürt.

    Da merkt man wahrscheinlich ein anderes Gasmapping eher.


    Im Anhang ist das Leistungsdiagramm einer Dorso 750 vor/nach der Optimierung.

    Vorher: 85 PS / 68 NM

    Nachher: 91 PS / 71 NM

    Der Drehzahlbegrenzer wurde um 500 U/Min angehoben.


    Bitte melden Sie sich an, um diesen Anhang zu sehen.

    Gruß

    Michael


    Due cilindri e basta! :bier